Page 1 of 1

iWork Numbers 2.0.5

PostPosted: Sun Sep 04, 2011 11:51 am
by RexinMinn
My "Function" is not functioning.

I'm using Numbers 2.0.5 and it won't add a column of numbers for me.

Is this a sign that I need to update or is there something simple I'm not doing which is somehow preventing the Function from working correctly? (or something far more sinister at work?) It is the "sum" function I'm interested in using at the moment. I have not checked the others.

Things I've already done:

1. checked inspector to make sure settings are correct
2. saved the document
3. tried another column in the spreadsheet (same thing happened)
4. closed document, re-opened it and tried again to use "sum"

Andover, MN

Re: iWork Numbers 2.0.5

PostPosted: Sun Sep 04, 2011 8:17 pm
by Peggy
Are the cells formatted as number rather than text?

Re: iWork Numbers 2.0.5

PostPosted: Mon Sep 05, 2011 12:18 am
by RexinMinn
They are formatted in text.
When an attempt to complete a "sum" function, the following comes up within the blank cell below the list of addends: =SUM(C30:C39)
When the format is changed to "number" the sum always appears as zero ("0").

Thanks for your help.

Re: iWork Numbers 2.0.5

PostPosted: Mon Sep 05, 2011 10:36 am
by Peggy
I probably should have reversed the order in my original reply. The cells need to be formatted as numbers in order to do mathematical calculations.

Formatting cells as text is the way to keep Numbers from making the contents some kind of number. It's good for any number that has leading zeroes you want to keep.

Re: iWork Numbers 2.0.5

PostPosted: Mon Sep 05, 2011 11:51 am
by RexinMinn

Thank you for that.
My wife and I collaborated to discover the problem late last night.
You asked, essentially, if I had my values formatted properly, and I replied that I did. You were on the right track, but at that point it didn't matter how I formatted them, because nothing was working.
And the reason for that is this: I had highlighted/selected only one cell (my "sum" cell), then checked the Inspector to see how it was formatted. I really thought this was the correct way to check. But my wife told me I needed to have the entire column highlighted. After we did that and selected the correct format, the functions worked properly again.
Thanks for helping me out with this and have a great Labor Day! :)